QuoteWerks Support Forum
QuoteWerks Support Forum
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 QuoteWerks
 Installation and Upgrades
 Runtime error '339' when using remoteapp
 New Topic  Reply to Topic
 Printer Friendly
Author  Topic Next Topic  

danm
New Member

1 Posts

Posted - 07/14/2017 :  11:08:48  Show Profile  Reply with Quote
Hi,

We have quotewerks installed on an application server. The users access it via an using it as a remoteapp or via the RDS server. All servers are Server 2012 R2 and have Webroot AV on them. All Quotewerks users are local admins on the RDS server and I have got them to change the mode to install before they run nsetup on the RDS server.

We are constantly getting runtime error 339 when accessing Quotewerks after not accessing the application for a certain amount of time. So they'd use it in the morning, come out of it and go back into 5/10 minutes later and it would work. If they were to close it and go back in 2 hours later they would get Runtime error 339 and have to run nsetup.exe again. Logging off or rebooting makes no difference. I have logged off the server and qw work fine once it has booted back up. I have checked and the user sessions are logging off correctly both when qw works and doesn't work.

I realise that this error means it is not writing something to somewhere on the system however there have been times when the user has gone back in an hour later and everything is fine so there doesn't seem to be a specific amount of time before this problem occurs.

I have checked all group policies and cannot find any that erase changes made to the system or delete profiles etc after a certain amount of time. The C drive is hidden by default but the quoetwerks users are all local admins on the RDS server so can access it and the system32/syswow64 folders.

This was all working fine up until someone rebooted the App server the other day and I've pretty much run out of ideas.

Any help greatly appreciated.

Thanks
Dan

stevesiggs
QuoteWerks Genius

United Kingdom
2137 Posts

Posted - 07/17/2017 :  05:10:36  Show Profile  Visit stevesiggs's Homepage  Reply with Quote
quote:
Originally posted by danm

All Quotewerks users are local admins on the RDS server and I have got them to change the mode to install before they run nsetup on the RDS server

The QuoteWerks nsetup.exe installation should just need to be run ONCE (preferably under the Administrator profile) with the server in install mode ("change user /install" from command prompt) with any AV/firewall software temporarily switch off (if you are experiencing issues). Each User should not have to run the nsetup.exe program and this may be why things are going wrong - one User runs it which knocks it out for others, then another runs it and knocks it out for the first User.

Suggest getting all Users out of QuoteWerks, uninstalling and the re-installing. Do this as Administrator, AV/firewall off and double-check User permissions to the QuoteWerks directory allow "Full Access".

Hope this helps,

Stephen Siggs
Hilltops IT / ConnectIt Software
QuoteWerks Solution & Development Partner since 2005

Skype: stephen.siggs
Tel: +44(0) 344 357 7360
Cell: +44(0) 7875 423661
Email: steve@hilltopsit.co.uk
QuoteWerks services - www.hilltopsit.co.uk/quotewerks
QuoteWerks add-ons - www.connectit-software.co.uk
Go to Top of Page
   Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
QuoteWerks Support Forum © Aspire Technologies, Inc Go To Top Of Page
Snitz Forums 2000