[Archived] QuoteWerks Support Forum - New Forum: https://tickets.quotewerks.com/support/discussions
[Archived] QuoteWerks Support Forum - New Forum: https://tickets.quotewerks.com/support/discussions
Home | Profile | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 QuoteWerks Real-time Module & Etilize Subscription
 Real-time Module
 TLSv1.2 for Synnex
 Forum Locked
 Printer Friendly
Author Topic  

doxdanp
QuoteWerks Enthusiast

USA
22 Posts

Posted - 02/03/2016 :  10:02:54  Show Profile  Visit doxdanp's Homepage
Synnex will require TLSv1.2 on XML requests as of March 11. (See below.)

I assume this is regarding realtime pricing. Is the TLS version adjustable within QuoteWerks or will we receive a software update? Or is this more of a firewall issue in our environment?

E-mail received from Synnex:

quote:

Dear Synnex Partner,

In a world where many businesses have experienced security breaches, Synnex is working diligently to stay ahead of the game to close down known compromised security protocols and implement new ones as they are made available. To provide a higher level of privacy and data security, Synnex’s XML environment is moving to more secure protocol as defined by the PCI Security Standards Council. We are eliminating the older TLS versions from our environment and moving to using TLSv1.2 only.
We have been monitoring XML traffic the past 2 months (December and January) and your acct/userid has been flagged as a partner that is submitting XML requests using a security protocol that is not TLSv1.2. We will need you to update your security protocol on your environment to submit XML requests to Synnex using TLSv1.2. This will ensure that connections between your environment and the Synnex Environment are using the latest security protocol. To clarify we are eliminating TLSv1.0 and TLSv1.1 and will be using only TLSv1.2. We are not requesting you to eliminate the 2 older TLS version, that is a Corporate decision on your side, what we need you to do is make sure TLSv1.2 is enabled as that will be the security protocol that is used for the handshake with Synnex
The go-live for this change on the Synnex side will be end of day on March 11th. On that date we will be blocking all XML requests received that do not use TLSv1.2. Too ensure continuity of service please work with your IT departments or XML 3rd party providers to update your environments.
Please do not wait till that weekend to make this change, you can make this change now and you will not be impacted
If you are not your companies IT Contact and are not familiar with what needs to be done, please forward this email to your IT department

A copy of this email will also be sent to your Synnex Sales Rep to keep them informed of this change and a follow-up email will be sent as we get closer to the go live date
If you have already made this change please disregard this email and thank you

Any concerns please contact me directly

Thank you,

Andy Verra - IT Manager, MobilitySolv, ServiceSolv, XML Group, PrintSolv, ESD, Enterprise Group | Synnex Corporation
Office: 416-240-2689 | Cell: 905-580-1576 | e-mail: andyv@synnex.com
#61520;#61472;Please consider the environment before printing this email.

qw_Shawn
Technical Support Manager

USA
765 Posts

Posted - 02/08/2016 :  16:16:53  Show Profile  Visit qw_Shawn's Homepage
Our Development Team is currently looking into this. Synnex has set their cut over date to March 11th. Before that time, there should be no interruption in service. If our Developers do find that an update is required, we will make that available long before Synnex's cut over date of March 11th.
We should know more by the end of the week after our Developers have had time to look into the issue further.

Best Regards,

Shawn McNamara
QuoteWerks Technical Support, Level 4
QuoteWerks Team Member Since June 2010
Aspire Technologies, Inc.

See our Tips & Tricks videos on our YouTube Channel www.youtube.com/quotewerks
Go to Top of Page

bebert
New Member

USA
4 Posts

Posted - 02/19/2016 :  10:05:17  Show Profile
QuoteWerks Team -

Do you have any updates on this TLSv1.2 change and Synnex? Is there a fix/update or setting we can change to be compliant? Thanks
Go to Top of Page

qw_Shawn
Technical Support Manager

USA
765 Posts

Posted - 02/19/2016 :  10:16:42  Show Profile  Visit qw_Shawn's Homepage
Our Development Team is currently finalizing an update to QuoteWerks to accommodate this change in Synnex's XML operations. However, there will be some level of configuration required for end user systems to guarantee operability after March 11th. We expect to have an update, as well as instructions on what is required on the end user's part, within the next week or two -- if not sooner.

Best Regards,

Shawn McNamara
QuoteWerks Technical Support, Level 4
QuoteWerks Team Member Since June 2010
Aspire Technologies, Inc.

See our Tips & Tricks videos on our YouTube Channel www.youtube.com/quotewerks
Go to Top of Page

bebert
New Member

USA
4 Posts

Posted - 02/19/2016 :  11:23:46  Show Profile
Thanks for the update!!
Go to Top of Page

qw_Shawn
Technical Support Manager

USA
765 Posts

Posted - 02/19/2016 :  12:19:37  Show Profile  Visit qw_Shawn's Homepage
Effective March 11th, 2016 SYNNEX now requires all XML queries to be sent using the TLS 1.2 protocol. QuoteWerks now supports this as of Version 5.1 Build 4.17. You can get access to our current interim containing this fix by contacting our Technical Support Team at: support@quotewerks.com

(If you have contacted us previously concerning this issue, you will be getting a response on your ticket; there is no reason to contact us a second time.)

The TLS v1.2 protocol is not available on Windows OS systems earlier than Windows 7. So any users that wish to use QuoteWerks (or any other software) to interact with SYNNEX XML services will need to be running the software on Windows 7 or higher. Additionally TLS 1.2 requires that the Microsoft .NET framework version 4.5 be installed and Internet Explorer (IE) 11 or higher needs to be installed. In Microsoft IE, TLS 1.2 must be enabled. To enable, click on the Gear/Settings button in IE and select Internet Options from the menu. Go to the Advanced tab, and under the Security section, make sure that TLS v1.2 is checked.

Best Regards,

Shawn McNamara
QuoteWerks Technical Support, Level 4
QuoteWerks Team Member Since June 2010
Aspire Technologies, Inc.

See our Tips & Tricks videos on our YouTube Channel www.youtube.com/quotewerks
Go to Top of Page
  Topic  
 Forum Locked
 Printer Friendly
Jump To:
[Archived] QuoteWerks Support Forum - New Forum: https://tickets.quotewerks.com/support/discussions © Aspire Technologies, Inc Go To Top Of Page
Snitz Forums 2000