[Archived] QuoteWerks Support Forum - New Forum: https://tickets.quotewerks.com/support/discussions
[Archived] QuoteWerks Support Forum - New Forum: https://tickets.quotewerks.com/support/discussions
Home | Profile | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 QuoteWerks
 Installation and Upgrades
 Rehosting to SQL
 Forum Locked
 Printer Friendly
Author Topic  

JessieLulham
New Member

USA
1 Posts

Posted - 07/25/2016 :  12:32:29  Show Profile
I have the corporate edition and am attempting to rehost to sql, however nothing is working. I have gone through multiple threads which addressed many issue and am still having issues.

1st issue i had to resolve:
SQL server must be set up as mixed authentication... resolved

2nd issue:
Login failed for sa. Unable to connect to SQL server using supplied values. --unresolved

now I have even gone to the lengths of creating a whole new login and giving it full permissions to create a database etc and still no luck, I just keep getting error (-2147217843)


JL

MattPrestige
QuoteWerks Genius

United Kingdom
531 Posts

Posted - 07/25/2016 :  12:54:47  Show Profile  Visit MattPrestige's Homepage
Would you like assistance via an online session?
www.join.me/prestigequoting

QuoteWerks MVP for 7 years
Remote QuoteWerks consultancy for companies globally.

matt@prestigequoting.com
www.prestigequoting.com
Go to Top of Page

qw_Shawn
Technical Support Manager

USA
765 Posts

Posted - 07/25/2016 :  14:22:46  Show Profile  Visit qw_Shawn's Homepage
This may help...

Issue:
When attempting to connect a workstation, or attempting to synchronize with the master installation the end user receives the following error message:

"Error: (-2147467259). Error opening connection in ConnOpen()
SQL Server does not exist or access denied"

Cause:
While you're able to access the shared Master QuoteWerks folder across the VPN, and you can also likely ping or "see" the SQL Server you're attempting to sync with, QuoteWerks is unable to access it.

In many cases this is because your machine is unable to resolve the name of the SQL server to it's IP address when connected via VPN.

Solution 1:

1) Go into Control Panel -> Administrative Tools -> Services and make sure the SQL Browser service is started on both the server and the remote system.

2) Next, on both the server and the remote, go into Start -> Programs (or All Programs) -> Microsoft SQL Server 2005 (or Express) -> Configuration Tools -> SQL Server Configuration Manager. Once that's up, expand the option for Network Configuration, select the option below for Protocols and then Enable TCP/IP.

Try the sync/connect again, it should now detect and access the server.

Solution 2:

Add a host entry for the SQL Server's computer name into the Windows Hosts file.

(C:\WINDOWS\system32\drivers\etc\hosts)

This will allow your machine to resolve the Server Name to it's IP address and will then allow QuoteWerks to find the SQL Server.

See the instructions in the host file itself for proper syntax, etc.


If the above solutions did not assist with resolving the issue, then there is some other underlying element causing the connectivity issue. To aid in testing (and keep you from having to load QuoteWerks every time) Technical Support has a database testing tool that you can download:
http://qwsupport.com/upload/files/databasetester.zip

You enter a connection string like (for example):

"PROVIDER = MSDASQL;driver={SQL Server};database=QuoteWerks;server=CWARD01\CATZSQL1;uid=QWLocal;pwd=password;"

If this testing tool is able to make the connection to the SQL server, then QuoteWerks should be able to as well.


Further, more detailed, information concerning troubleshooting connectivity to the SQL server can be found on Microsoft's website: http://social.technet.microsoft.com/wiki/contents/articles/2102.how-to-troubleshoot-connecting-to-the-sql-server-database-engine.aspx

In addition, there may also be an issue related to the Named Pipes Provider. End users will receive a, "error: 40 - Could not open a connection to SQL Server" This is resolve using the following: http://blogs.msdn.com/b/sql_protocols/archive/2007/03/31/named-pipes-provider-error-40-could-not-open-a-connection-to-sql-server.aspx


Dynamic Ports and SQL Express:
=============================
By default, named instances (including SQL Server Express) use dynamic ports (it should be noted that if used in conjunction with QuoteWerks, the SQL server cannot use dynamic port assignment; it must be using port 1433.). That means that every time that the Database Engine starts, it identifies an available port and uses that port number. If the named instance is the only instance of the Database Engine installed, it will probably use TCP port 1433. If other instances of the Database Engine are installed, it will probably use a different TCP port. Because the port selected might change every time that the Database Engine is started, it is difficult to configure the firewall to enable access to the correct port number. Therefore, if a firewall is used, we recommend reconfiguring the Database Engine to use the same port number every time. This is called a fixed port or a static port. For more information, see Configure a Server to Listen on a Specific TCP Port (SQL Server Configuration Manager).
Ports used by database engine: https://msdn.microsoft.com/en-us/library/cc646023(v=sql.110).aspx#BKMK_ssde
Configuring the Listening Port: https://msdn.microsoft.com/en-us/library/ms177440(v=sql.110).aspx


How to Test a Database Connection String using NotePad
http://www.gotknowhow.com/articles/test-a-database-connection-string-using-notepad

Best Regards,

Shawn McNamara
QuoteWerks Technical Support, Level 4
QuoteWerks Team Member Since June 2010
Aspire Technologies, Inc.

See our Tips & Tricks videos on our YouTube Channel www.youtube.com/quotewerks
Go to Top of Page

MattPrestige
QuoteWerks Genius

United Kingdom
531 Posts

Posted - 07/25/2016 :  14:33:53  Show Profile  Visit MattPrestige's Homepage
Was the former :)

QuoteWerks MVP for 7 years
Remote QuoteWerks consultancy for companies globally.

matt@prestigequoting.com
www.prestigequoting.com
Go to Top of Page

qw_Shawn
Technical Support Manager

USA
765 Posts

Posted - 07/26/2016 :  10:34:23  Show Profile  Visit qw_Shawn's Homepage
Almost always is.

Excellent work, Matt.

Best Regards,

Shawn McNamara
QuoteWerks Technical Support, Level 4
QuoteWerks Team Member Since June 2010
Aspire Technologies, Inc.

See our Tips & Tricks videos on our YouTube Channel www.youtube.com/quotewerks
Go to Top of Page
  Topic  
 Forum Locked
 Printer Friendly
Jump To:
[Archived] QuoteWerks Support Forum - New Forum: https://tickets.quotewerks.com/support/discussions © Aspire Technologies, Inc Go To Top Of Page
Snitz Forums 2000